How to handle "Version in package 1.0.0 is smaller than or equal to highest version 1.0.0 under vetting"


#1

I received a reply that my plugin was reject due to,

Rejection Reason: Version in package 1.0.0 is smaller than or equal to highest version 1.0.0 under vetting

What does this mean?

In my manifest I have:

"name": "My Plugin",
"id": "the_id",
"version": "1.0.0"

#2

Is the plugin one that’s already in the plugin manager? If so, the version will need to be higher than what’s already in the plugin manager.


#3

I’ve only submitted once. I can submit a new version with a higher version number and see if it fixes it.


#4

Could it be referring to the host version number?

This is what I have in my manifest:

"host": {
    "app": "XD",
    "minVersion": "13.0.0.0"
},

Some have said it won’t accept “13.0” so maybe “13.0.0.0” is not valid either (the number in the about dialog has 4 places).


#5

Yeah; make sure it’s a three part version. I think 13.0.0.0 will get caught in the rejected filter.


#6

I updated the version number and changed the min version number to 3 places, “13.0.0” and one of those two things worked because it was accepted. :slight_smile: